• Members 1 post
    Dec. 11, 2017, 7:28 a.m.

    I always use "armor inspector" This application is very helpful, but if I mention the points that I care about the live view function.
    Although I learned about how to use this function on this site, it seems that the numerical value entered in the text column is not reflected when entering the IP address in the application.
    Because this function is most interesting, if this is a bug, I'd like you to fix it

    Translate from Japanese by google

  • Dec. 17, 2017, 1:57 p.m.


    Do you mean that you can't enter IP address? Or IP address didn't popup in the game? Or when you've entered it correctly the app still doesn't connect?

    If the app doesn't connect to a PC, in most cases it means that the PC is refusing incoming connection because of strict network configuration, or that the app and PC are not connected to one local network.

    First thing to check is that PC and app on iOS or Android are in same network. They should be connected to the same WiFi router for example. Also please check the IP address of your mobile device. You can do that by visiting the settings on the smartphone and checking the properties of WLAN there. The fist 3 numbers of IP address of your device should match the first 3 numbers of IP address of your PC.

    The second case is that PC may reject the connection from smartphone or tablet. Try to disable firewall on your PC if you have one enabled and then try to connect again.

    Keep in mind that Armor Inspector is subject to wargaming's fair play policy. Once connected the app will simulate every shot you've made to enemy or vice versa, but the camera won't be fully synchronized, that's because full camera synchronization may give an advantage to the player according to wargaming and they ask to disable this feature during the battle. However, full camera synchronization is enabled in replays.

    Let me know if you have more questions.

  • Members 9 posts
    Jan. 30, 2018, 9:35 a.m.

    Hello I am having issues with the live view too...I'm not sure if i'm installing the download in the right file. After I extract the file to my desktop I drag and drop
    the SCRIPT file in WORLD OF TANKS / RES_MODS / folder and merge the file to what i already have in their. After I start the game it doesn't give any message or anything like that. I also try to connect with no luck can you explain exactly were I have to install the fill please. Does the RES-MODS file need to be empty or something...

    Thanks in Advance!

  • Jan. 30, 2018, 10:46 a.m.

    Could you attach python.log file to check whether the mod is installed correctly? I'll take a look.

  • Members 9 posts
    Jan. 30, 2018, 9:07 p.m.

    Well I removed it already till I get conformation on how to install correctly

  • Members 9 posts
    Jan. 30, 2018, 9:11 p.m.

    Also I don't think I can upload that file.

  • Jan. 30, 2018, 9:21 p.m.

    Ok, the *.pyc files should be put into res_mods/ folder, like on this picture (mod_armorinspector.pyc rests with other mods in the same folder).

    But then, the mod may have conflicts with other mods, especially the hangar ones, like battle statistics and others. In this case the message in the hangar with IP to connect might not be shown. If you can't upload python.log, you can check it for yourself whether the mod is installed correctly. When you start the game, look for the line in the python.log

    2018-01-29 02:01:04.717: INFO: Armor Inspector started at on port 8001

    This line means that the mod is installed and tells the IP to use to connect your smartphone or tablet. Keep in mind that your device should be connected to the same wifi as PC.

  • Members 9 posts
    Jan. 30, 2018, 9:55 p.m.

    Yes as far as being on the same network as my pc. So this is what I will do I will copy then paste the file in the file and merge them and take a look in the python.log and get back to you. Thanks

  • Members 9 posts
    Jan. 30, 2018, 10:19 p.m.

    So after installing and checking the python.log... yes it turns out their is an error with the Hanger mod and notification tab so i'm going to un-install that mod and try it again.

  • Members 9 posts
    Jan. 30, 2018, 10:37 p.m.

    So it turns out their is still some sort of error. I attached the python file

    python.log 1.txt

    Text, 11.0 KB, uploaded by amad007.na on Jan. 30, 2018.

  • Members 9 posts
    Jan. 31, 2018, 8:31 p.m.

    Let me know if you can make out what is going on.

    Thanks for your help.

  • Jan. 31, 2018, 8:45 p.m.

    Yes, there is an issue with hangar mod showing there is conflict with one of hangar mods and armor inspector mod. I'll take a look whether it's my fault or not. In the meantime the armor inspector mod is installed correctly, it prints the message in the log "Armor Inspector started at on port 8001", so you can try to use that IP to connect your smartphone or tablet.

  • Members 9 posts
    Jan. 31, 2018, 10:01 p.m.

    Thanks for the info. I did see that the IP shows up and I tried to enter the address on my device and after changing it the the correct IP i press the done or enter tab and it doesn't change to the new IP I enter. It stays on the default IP that is already in the live view mode tab.
    What can I do to enter the new IP in my device because it will not change?

  • Feb. 2, 2018, 10:23 a.m.

    Just checked the Android version. Yes, it seems to be broken. It doesn't allow to enter IP, it stays the default one. I will fix it ASAP and return to you. The iOS version seems to work just fine.

  • Feb. 2, 2018, 3:22 p.m.

    Please try the new version from Google Play

  • Members 9 posts
    Feb. 2, 2018, 8:38 p.m.

    Thanks it's working now. I still get an issue that It seems I can't run the mod with some other mod not sure witch one and causes notification tab to get stuck in hanger I'll have to uninstall it before I clear my notifications so it won't get stuck in the garage.

    Again thank you for your time and help very much appreciate it!